corrupt digital camera memory card?

Former MemberFormer Member Posts: 1,876,329 The Mix Honorary Guru
ok, i bought a 64mb securedigital card from Klick Photopoint about 2 months ago. its worked fine, up until last week when i was taking photos on my camera, when the battery ran out. i turned it off+then later on turned it on to take 1 last photo. Normally if the battery's going flat, if i turn it off for an hour or so, it'll stay on for about 2 mins. However, when i turned my camera on it wouldn't come on at all. Ive changed the batteries etc, but to joy, so ive just put my memory card in my b.f's digital camera.
But it wont work in his either, exactly the same thing happens, yet his card (identical to mine) works fine and his camera works without the card :crazyeyes
im going to go back to the shop, bcos surely this shouldn't happen after only 2 months! any ideas why???
thanx, cos this has annoyed me, ive lost so many lovely pics :(

Comments

  • Former MemberFormer Member Posts: 1,876,329 The Mix Honorary Guru
    ok, i bought a 64mb securedigital card from Klick Photopoint about 2 months ago. its worked fine, up until last week when i was taking photos on my camera, when the battery ran out. i turned it off+then later on turned it on to take 1 last photo. Normally if the battery's going flat, if i turn it off for an hour or so, it'll stay on for about 2 mins. However, when i turned my camera on it wouldn't come on at all. Ive changed the batteries etc, but to joy, so ive just put my memory card in my b.f's digital camera.
    But it wont work in his either, exactly the same thing happens, yet his card (identical to mine) works fine and his camera works without the card :crazyeyes
    im going to go back to the shop, bcos surely this shouldn't happen after only 2 months! any ideas why???
    thanx, cos this has annoyed me, ive lost so many lovely pics :(


    reformat it

    http://panasonic.co.jp/pavc/global/cs/sd/faq/formQA.html
  • Former MemberFormer Member Posts: 1,876,329 The Mix Honorary Guru
    ooo, thanx for that. didnt know you could do that. il give it a whirl tomo.
  • Former MemberFormer Member Posts: 1,876,329 The Mix Honorary Guru
    assuming you don't mind losing the photos, a reformat should fix all your woes. *nods at Diamond*
  • Former MemberFormer Member Posts: 1,876,329 The Mix Honorary Guru
    The first digicam i had was a 640K pixel from samsung and to charge the flash took the whole power from both of my new AA batteries. So it was costing me 2 batterys per photo in the dark and rechargeable ones didnt work at all. What do you think went wrong there?
Sign In or Register to comment.