Home General Chat
If you need urgent support, call 999 or go to your nearest A&E. To contact our Crisis Messenger (open 24/7) text THEMIX to 85258.
Read the community guidelines before posting ✨
Aged 16-25? Share your experience of using the discussion boards and receive a £25 voucher! Take part via text-chat, video or phone. Click here to find out more and to take part.
Options

IIS Problem

Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
I'm hosting a website on my home PC using IIS. In the past I was able to access my site from any PC on the Net but now something has gone very wrong and I can only view the site on the PC on which it's running and other PCs within the network. :confused: I've checked the firewall logs and no packets are being stopped when friends outside of the network try to view my site but then it runs on port 80, the same as the Internet, so I didn't expect it to be closed. Are there any settings in IIS Admin that stop external traffic that I may have inadvertantly changed? Does anyone have any idea why this thing is being a dog all of a sudden?

Thanks

Comments

  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    Erm. The only tabs which would prevent it are either in the security (if say Windows Authentication only is turned on), but then you would get an error message like access denied or similar, or the page that controls which IPs are restricted from viewing sites (I can't remember off hand what this page is called or where you access it from, it's either in the global config or within the site config).

    Otherwise check what else has changed on the server. EG if a firewall has been turned on or changed, do you still have network connectivity from the web server?
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    I've run the Permissions Wizard and changed a couple of settings. Would you see if you can access the darn thing please?

    http://82.43.148.70/WebHelpdesk/samanta.asp - case sensitive

    Thanks.
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    Doesn't seem like it. No response, it just times out after a while, so the packets are probably not being routed either in or out or both.
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    packets are probably not being routed

    But it's on port 80. So if packets are being block the Internet wouldn't work right?

    If I forward all port 80 packets to me then won't everyone else on the router be screwed out of Internet?

    Also I'm sure I never had port 80 forwarded before & it was working. Why must this be a troll bitch from hell, why oh why?
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    Not really. Packets *outbound* to port 80 (on a remote server) are needed to browse the net. On your machine acting as the server you would need port 80 traffic inbound to be allowed and / or forwarded.
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    I've forwared port 80 to my PC on TCP & UDP - not entire sure this is correct as I was expecting an HTTP option! Please may you check to see if it is working?

    http://82.43.148.70/WebHelpdesk/samantha.asp
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    Originally posted by Koenigsegg
    I've forwared port 80 to my PC on TCP & UDP - not entire sure this is correct as I was expecting an HTTP option! Please may you check to see if it is working?

    http://82.43.148.70/WebHelpdesk/samantha.asp

    You would only need tcp.

    Something has changed as it now fails a lot more quickly. It possibly means that the port is now open but a server is not accepting connections.
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    Hi Moo it's the Koenigsegg in disguise as an M12 GTO - sick little trick I know, but I've forgotten the Koenigsegg password.

    The darn thing is finaly working thanks to your help and advice. It didn't work after I opened the port because the port was STILL blocked by default even though I opened it so I had to delete the block rule & now it works like a Honda VTEC system.

    Thanks again Moo, I'll e-mail you some grass. :birthday:
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    :thumb:
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    tis not working for me
  • Options
    Former MemberFormer Member Posts: 1,876,323 The Mix Honorary Guru
    My computer probably wasn't on or I was on my neighbours Internet <Koenigsegg>
Sign In or Register to comment.